Amy (amyxaphania) wrote in vaginapagina,
Amy
amyxaphania
vaginapagina

UTI Advice

Hi all.

I know UTIs get posted about a lot so please bear with me!



About four weeks ago, I got the symptoms of a urine infection - slight pain, smelly/cloudy urine and the horrible urge to pee all the time. I went to the doctors the next day and got some antibiotics, finished the course and thought everything was okay. Couple of days later, I had the symptoms again - another trip to the doctor, gave a urine sample and the infection was still there. Got prescribed another set of antibiotics and again, finished the course.

The day after finishing the second course I began to feel symptoms again, the constant urge to pee and a little burning. I booked another appointment at the doctors, and took a urine sample with me. He said that the sample showed no sign of infection, but he did prescribe me more antibiotics and told me to take them if I still felt symptoms after 24 hours. That was about a week and a half ago, and up until now I have been fine.

I did get the prescription filled so have the antibiotics (they're called Keflex) but didn't take any as I thought everything was okay.

However today I've been getting the constant urge to pee again, though there are no other symptoms. My question is - should I use the antibiotics that I was prescribed a week and a half ago, even though I'm not sure if it's definitely the infection back again? Or should I see the doctor again (which I wouldn't be able to do until Friday morning)?

Am a bit wary of going onto another round of antibiotics (particularly as just before the UTI began I had an abcess for which I was also on antibiotics for).

I'm just getting sick of constantly needing the loo, particularly as at my workplace I don't have easy access to a toilet.

Thanks for reading!

Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 8 comments